Ошибка pfSense: “Shared object “libarchive.so.7″ not found”

Print Friendly, PDF & Email

Задача:

Исправить ошибку в консоли pfSense. Ошибка: “Shared object “libarchive.so.7” not found, required by “pkg” появляется при попытке обновления из консоли сервера.

---------------------------------------------------------------

Первым делом пробуем bootstrap

[2.4.5-RELEASE][root@gw.local]/root: pkg bootstrap -f
The package management tool is not yet installed on your system.
Do you want to fetch and install it now? [y/N]: y
Bootstrapping pkg from pkg+https://pkg.pfsense.org/pfSense_v2_4_5_amd64-pfSense_v2_4_5, please wait...
Verifying signature with trusted certificate pkg.pfsense.org.20160406... done
Installing pkg-1.12.0_1...
package pkg is already installed, forced install
Extracting pkg-1.12.0_1: 100%
[2.4.5-RELEASE][root@gw.local]/root:

Если не помогло пробуем установить

[2.4.5-RELEASE][root@gw.local]/root: pkg install -f pkg
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
        pkg-1.12.0_1 [pfSense]

Number of packages to be reinstalled: 1

Proceed with this action? [y/N]: y
[1/1] Reinstalling pkg-1.12.0_1...
[1/1] Extracting pkg-1.12.0_1: 100%
You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
[2.4.5-RELEASE][root@gw.local]/root:

Проверяем

[2.4.5-RELEASE][root@gw.local]/root: pkg upgrade
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking for upgrades (11 candidates): 100%
Processing candidates (11 candidates): 100%
The following 10 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
        sshguard: 2.4.0_3,1 -> 2.4.0_4,1 [pfSense]
        python37: 3.7.6 -> 3.7.7 [pfSense]
        python27: 2.7.17_1 -> 2.7.18 [pfSense]
        py37-yaml: 5.2 -> 5.3.1 [pfSense]
        pfSense-pkg-openvpn-client-export: 1.4.22 -> 1.4.23 [pfSense]
        pfSense-pkg-ntopng: 0.8.13_3 -> 0.8.13_5 [pfSense]
        pfSense-pkg-arpwatch: 0.2.0_2 -> 0.2.0_3 [pfSense]
        openvpn-client-export: 2.4.8 -> 2.4.9 [pfSense]
        openvpn: 2.4.8 -> 2.4.9 [pfSense]
        mysql57-client: 5.7.29 -> 5.7.30_1 [pfSense]

Number of packages to be upgraded: 10

45 MiB to be downloaded.

Proceed with this action? [y/N]: y
Please type 'Y[es]' or 'N[o]' to make a selection

Proceed with this action? [y/N]: Y
[1/10] Fetching sshguard-2.4.0_4,1.txz: 100%  468 KiB 478.8kB/s    00:01
[2/10] Fetching python37-3.7.7.txz: 100%   16 MiB   1.4MB/s    00:12
[3/10] Fetching python27-2.7.18.txz: 100%   11 MiB   1.1MB/s    00:10
[4/10] Fetching py37-yaml-5.3.1.txz: 100%   75 KiB  76.7kB/s    00:01
[5/10] Fetching pfSense-pkg-openvpn-client-export-1.4.23.txz: 100%   21 KiB  21.5kB/s    00:01
[6/10] Fetching pfSense-pkg-ntopng-0.8.13_5.txz: 100%   10 KiB  10.6kB/s    00:01
[7/10] Fetching pfSense-pkg-arpwatch-0.2.0_3.txz: 100%    9 KiB   8.8kB/s    00:01
[8/10] Fetching openvpn-client-export-2.4.9.txz: 100%   15 MiB   1.3MB/s    00:12
[9/10] Fetching openvpn-2.4.9.txz: 100%  341 KiB 349.4kB/s    00:01
[10/10] Fetching mysql57-client-5.7.30_1.txz: 100%    2 MiB 497.8kB/s    00:04
Checking integrity... done (0 conflicting)
[1/10] Upgrading python37 from 3.7.6 to 3.7.7...
[1/10] Extracting python37-3.7.7: 100%
[2/10] Upgrading openvpn from 2.4.8 to 2.4.9...
[2/10] Extracting openvpn-2.4.9: 100%
[3/10] Upgrading mysql57-client from 5.7.29 to 5.7.30_1...
[3/10] Extracting mysql57-client-5.7.30_1: 100%
[4/10] Upgrading openvpn-client-export from 2.4.8 to 2.4.9...
[4/10] Extracting openvpn-client-export-2.4.9: 100%
[5/10] Upgrading sshguard from 2.4.0_3,1 to 2.4.0_4,1...
[5/10] Extracting sshguard-2.4.0_4,1: 100%
You may need to manually remove /usr/local/etc/sshguard.conf if it is no longer needed.
[6/10] Upgrading python27 from 2.7.17_1 to 2.7.18...
[6/10] Extracting python27-2.7.18: 100%
[7/10] Upgrading py37-yaml from 5.2 to 5.3.1...
[7/10] Extracting py37-yaml-5.3.1: 100%
[8/10] Upgrading pfSense-pkg-openvpn-client-export from 1.4.22 to 1.4.23...
[8/10] Extracting pfSense-pkg-openvpn-client-export-1.4.23: 100%
Removing openvpn-client-export components...
Loading package instructions...
Saving updated package information...
overwrite!
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Writing configuration... done.
[9/10] Upgrading pfSense-pkg-ntopng from 0.8.13_3 to 0.8.13_5...
[9/10] Extracting pfSense-pkg-ntopng-0.8.13_5: 100%
Removing ntopng components...
Menu items... done.
Services... done.
Loading package instructions...
Deinstall commands... done.
Saving updated package information...
overwrite!
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Executing custom_php_install_command()...done.
Executing custom_php_resync_config_command()...done.
Menu items... done.
Services... done.
Writing configuration... done.
[10/10] Upgrading pfSense-pkg-arpwatch from 0.2.0_2 to 0.2.0_3...
[10/10] Extracting pfSense-pkg-arpwatch-0.2.0_3: 100%
Removing arpwatch components...
Menu items... done.
Services... done.
Loading package instructions...
Deinstall commands... done.
Saving updated package information...
overwrite!
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Executing custom_php_install_command()...done.
Executing custom_php_resync_config_command()...done.
Menu items... done.
Services... done.
Writing configuration... done.
=====
Message from python27-2.7.18:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
[2.4.5-RELEASE][root@gw.local]/root:

Помогла статья? Есть возможность отблагодарить автора

Читайте также:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *